Программный комплекс "Фрегат2005" предназначен для pазpаботки и отладки программ пpомышленных контроллеров семейства УПУ-ТП специалистами по автоматическому управлению и регулированию технологических пpоцессов.
"Фрегат2005" обеспечивает дистанционное управление ПЛК по протоколу TCP через различные каналы связи (Ethernet, Internet).
Термином ПЛК далее в тексте обозначаются аппаратные средства семейства УПУ-ТП, выпускаемые ООО АВТОМАТИКА плюс.
Программный комплекс может быть установлен на персональных компьютерах под управлением операционных систем Windows 98SE и старше.
Описываемая в данном руководстве подсистема SCADA-HMI находится в стадии разработки и не рекомендуется для самостоятельного применения в ответственных узлах систем управления. По вопросам применения SCADA-HMI обращайтесь к специалистам ООО Автоматика плюс.
Функциональная схема ПО приведена на Рис. 1.
Функции кнопок управления:
Главное окно Фрегат2005 содержит пользовательский интерфейс для общего управления разработкой программы ПЛК: управляет созданием, загрузкой и сохранением проектов и настроек, а также содержит справочник по аппаратуре ПЛК. Базовый модуль «Фрегат2005» представляет собой исполняемый файл среды .Net в состав которого входят окна субмодулей «Проект», «Программа», редакторы исходных текстов языков LAD,STL, «Таблица символов», «Аппаратная конфигурация». Пользовательский интерфейс построен на основе панелей документов. Документы и функциональные окна субмодулей распологаются на собственных панелях с различными визуальными вариантами размещения. Размещение панелей контролирует пользователь. Функции субмодулей становятся доступными при открытии окна субмодуля имеющего одноименный заголовок.
Функции разделов главного меню модуля:
Окно списка последних проектов доступно сразу после запуска «Фрегат2005». Кнопка открытия файла открывает проект отмеченный в таблице. Проект можно открыть двойным нажатием на левый край таблицы с изображением стрелки.
Проект Фрегат2005 - это совокупность программ, данных и аппаратных настроек необходимых для выполнения поставленной задачи автоматизации в ПЛК.
Модуль "Проект" обеспечивает просмотр и навигацию по элементам проекта управляющей программы:
Доступ из главного меню: Вид - Окно проекта
"Программа" содержит таблицу функциональных блоков и набор кнопок управления.
Функции кнопок управления:
Двойное нажатие указателем мыши на левый край строки таблицы также открывает редактор исходного текста функционального блока. Кнопки снабжены всплывающими окнами подсказок.
Программа может состоять из одного или более функциональных блоков заданных на языках программирования LAD, FBD или STL. Функциональный блок содержит одну или несколько цепей. Цепь включает проверку логического выражения и установку одной выходной переменной, либо определение одного таймера, счетчика или функциональной команды.
В исходных текстах используются символьные имена соответствующие контактам ввода-вывода и внутренним областям памяти контроллера. Распределение адресов символьных имен происходит при сборке проекта.
При написании и отладке программыФрегат2005 используются символьные имена элементов вместо их адресов, что позволяет сохранять и повторно использовать функциональные блоки в разных проектах.
Автоматическая система распределения адресов настраивается субмодулем "Таблица символов" на различные варианты аппаратной конфигурации. Сохранена возможность ручного распределения адресов.
Программа Фрегат-2005 может быть использована без изменения исходных текстов при изменении аппаратной конфигурации ПЛК.
Порядок выполнения блоков может быть изменен в любой момент времени (как при создании исходного текста, так и позже, до момента сборки проекта) . Программа обеспечивает последовательное выполнение блоков и цепей в порядке их указания в исходном тексте на момент сборки.
Функции кнопок управления:
Окно "Таблица символов" обеспечивает ввод и отображение символических имен и таблицы перекрестных ссылок проекта.
модуль хранит символьную информацию проекта необходимую при разработке исходных текстов и сборке проекта. "Таблица символов" обеспечивает редактирование и управление свойствами символьных имен, просмотр перекрестных ссылок.
Кнопки управления окна выполняют функции: включить-выключить таблицу перекрестных ссылок, удалить неиспользуемые переменные, отменить сортировку строк таблицы символов, загрузить блок имен из файла, сохранить выбранные имена в файл.
При открытой таблице перекрестных ссылок нажатие на левый край строки ссылки открывает редактор исходного текста с определением данной ссылки.
Редактирование данных в таблице символов позволяет задать: автоматический-ручной тип распределения адресов, имя для адреса ввода-вывода или памяти, связать имя с контактом модуля ввода-вывода в аппаратной конфигурации проекта.
Функции кнопок управления:
Предназначен для создания и корректировки исходных текстов цепей, управления сборкой, загрузкой и отладкой проекта в ПЛК. Множество встроенных функций реализуется набором кнопок собственной панели инструментов.
Основные функции Редактора: добавить цепь, добавить элемент, добавить катушку (таймер, функциональную команду), вырезать-копировать-вставить-удалить элемент, сборка и загрузка проекта, установить режим слежения, показать-скрыть таблицу символов.
Ряд функций редактирования включается указателем мыши: выделить элемент или участок цепи, указать место добавления элемента.
На панели инструментов размещены элементы визуализации: количество видимых позиций элементов, вид отображения: выбранная цепь, либо все цепи.
Функции кнопок управления:
Предназначен для задания аппаратной конфигурации проекта.
В ходе задания конфигурации определяются типы модулей ввода-вывода и их базовые адреса. Кнопки управления выполняют сервисные функции: новая конфигурация, загрузить-сохранить конфигурацию, применить конфигурацию.
При задании типов блоков ввода-вывода должен быть открыт субмодуль "Справочник по аппаратуре". Установка блока ввода-вывода задается перетаскиванием модуля из окна справочника в окно конфигурации с помощью указателя мыши.
Предназначен для редактирования и просмотра справочной информации об аппаратуре семейства ПЛК, доступной для применения в проектах Фрегат2005.
Справочная информация сохраняется во внешнем файле Hardware.config.
Решает задачи: настройка соединения с "ФрегатСервер", подключение, выбор типа устройства (ПЛК или симулятор).
После установления соединения с "ФрегатСервер" становятся доступны функции: загрузка программы, управление (старт-стоп, пошаговый режим), просмотр состояния памяти ПЛК.
Модуль связи включает средства соединения с ФрегатСервер по протоколу TCP и панель дистанционного управления контроллером (ПДУ).
С помощью ПДУ можно установить соединение с ФрегатСервер, расположенным локально или удаленно. При установке связи указывается имя сервера или его TCP-адрес.
Средства: загрузка программы в контроллер или симулятор, пуск-остановка и пошаговый режим работы контроллера становятся доступными после установки соединения.
Средства отладки обеспечивают просмотр элементов программ и состояний переменных при работе программы как в симуляторе так и в устройстве ПЛК.
Средства отладки включают: элементы Модуля ПДУ (кнопки старт-стоп, пошаговый режим и индикаторы состояний вводов-выводов), функции слежения за состоянием переменных в редакторе LAD, симулятор ПЛК.
Возможен автоматический пошаговый режим с заданным интервалом между циклами, или ручной режим с запуском по нажатию кнопки пуск на Модуле ПДУ.
Представляет собой исполняемый файл среды .Net и группу динамических библиотек. После запуска "ФрегатСервер" в системном трее (правый нижний угол экрана системы) появляется значок . Для вызова панели настройки "ФрегатСервер", показанной на Рис.2.11.1, щелкните по этому значку.
"ФрегатСервер" непосредственно управляет контроллером через коммуникационный порт РС. Относительно модуля "ФрегатБаза", "ФрегатСервер" может быть установлен как дистанционно, например, на сетевом ПК, так и на одном рабочем месте.
Обозначения органов управления:
Функции групп параметров:
Настройки сервера
Вызываются нажатием на иконке сервера в системном трее (правый нижний угол экрана). Открывается панель свойств «Управление ФрегатСервер» в отдельном окне. Параметры сгруппированы по функциональному признаку, см. Рис. 2.11.2.
Запуск и остановка
Тип интерфейса
InterfaceType:Тип интерфейса для связи сервера с ПЛК. Возможные значения
Симулятор CPU165
Настройки NetPlc
Настройки HMI
Описываемая в данном руководстве подсистема SCADA-HMI находится в стадии разработки и не рекомендуется для самостоятельного применения в ответственных узлах систем управления. По вопросам применения SCADA-HMI обращайтесь к специалистам ООО Автоматика плюс.
Подсистема SCADA-HMI включает ряд модулей, расположенных во ФрегатСервер и Фрегат2005:
Обозначения:
Главное меню дизайнера совмещено с главным меню Фрегат2005.
При работе дизайнера в главное меню добавляются группы: «Формат» Рис 2.12.4., «Загрузка»; группа «Правка» заменяется собственной группой «Правка» дизайнера Рис 2.12.3.
В группу «Файл» добавляются элементы: «Создать» - «HMI», «Открыть»-«HMI»; группа «Сохранить» заменяется элементами «СохранитьHMI» и «Сохранить как», для сохранения проектов интерфейса в файл.
Интерфейс дизайнера состоит из окна документа «HMI дизайн» в центральной части экрана и панели свойств в правой части экрана.
Проект дизайна включает главную панель с расположенными на ней пассивными и активными элементами. Пассивные элементы могут содержать постоянные текст и (или) изображение. Активные элементы меняют текст и изображение в соответствии со значениями связанных переменных.
Элементы добавляются на форму при помощи меню «Правка-Добавить элемент» после чего выбирается нужный элемент, который добавляется на форму.
Чтобы переместить элемент на форме или изменить его размеры, пользуемся мышью и меню «Формат».
Работа мышью начинается с указания элемента (щелчок указателем над полем элемента), либо группы элементов (щелчок мышью с нажатой клавишей «Shift»). Активные элементы окружаются рамкой с метками по углам для изменения размеров.
Одновременно свойства элементов отображаются в окне «Настройки HMI» в левом углу экрана. Все действия выполняются для указанных элементов.
Удаление элемента выполняется с помощью меню «Правка-Удалить» или сочетанием клавиш «Shift+Del».
Панель «Настройки HMI» позволяет задавать свойства для одного или нескольки выделенных элементов.
Главное меню дизайнера совмещено с главным меню ФрегатБаза. При работе дизайнера в главное меню добавляются группы: «Формат», «Загрузка»; группа «Правка» заменяется собственной группой «Правка» дизайнера. В группу «Файл» добавляются элементы: «Создать» - «HMI», «Открыть»-«HMI»; группа «Сохранить» заменяется элементами «СохранитьHMI» и «Сохранить как», для сохранения проектов интерфейса в файл.
Интерфейс дизайнера состоит из окна документа «HMI дизайн» в центральной части экрана и панели свойств в правой части экрана.
Проект дизайна включает главную панель с расположенными на ней пассивными и активными элементами. Пассивные элементы могут содержать постоянные текст и (или) изображение. Активные элементы меняют текст и изображение в соответствии со значениями связанных переменных.
Элементы добавляются на форму при помощи меню «Правка-Добавить элемент…» после чего выбирается нужный элемент, который добавляется на форму.
Чтобы переместить элемент на форме или изменить его размеры, пользуемся мышью и меню «Формат».
Работа мышью начинается с указания элемента (щелчок указателем над полем элемента), либо группы элементов (щелчок мышью с нажатой клавишей «Shift»). Активные элементы окружаются рамкой с метками по углам для изменения размеров. Одновременно свойства элементов отображаются в окне «Настройки HMI» в левом углу экрана. Все действия выполняются для указанных элементов.
Удаление элемента выполняется с помощью меню «Правка-Удалить» или сочетанием клавиш «Shift+Del».
Панель «Настройки HMI» позволяет задавать свойства для одного или нескольки выделенных элементов.
Перед установкой ПО Фрегат необходимо установить Microsoft Net Framework 1.1 redistributable Package. Установить ПО Фрегат запустив файл инсталлятора fregat.exe. При дистанционном размещении модулей "ФрегатБаза" и "ФрегатСервер" на удаленном компьютере запустить файл инсталлятора fregatsvr.exe
Производится из окна "Проводника" ОС Windows двойным нажатием на файл fgat2005.exe, либо из пункта системного меню "Старт"-"Программы"-"Fregat2005"-"Fregat2005 Base".
Модуль "ФрегатСервер" на локальном компьютере запускается автоматически при запуске
"Фрегат2005".
На удаленном ПК запуск производится из окна "Проводника" ОС Windows двойным
нажатием на файл fserver.exe, либо из меню Windows "Старт"-"Выполнить".
Модуль "ФрегатСервер" содержит защиту ключом HardLock. Данная защита распространяется на динамическую библиотеку управления ПЛК. При использовании ПО с ПЛК ключ защиты необходимо разместить на компьютере с установленным модулем "ФрегатСервер".
По умолчанию в "общих настройках"-"соединения"-"autoconnect" установлено "true". При этом при запуске Фрегат2005 выполняет попытку соединиться к ПЛК с параметрами последнего сеанса. Для отключения следует перевести "autoconnect" в "false".
Соединение между базовым модулем "Фрегат2005" и "ФрегатСервер" необходимо перед проведением любых действий с ПЛК или симулятором, таких как: загрузка программы, чтение блоков данных, дистанционное управление и отладка.
Параметры соединения задаются в окне Модуля ПДУ как показано на Рис.3.2.1.
Для соединения необходимо задать следующие параметры:
После задания параметров установить соединение с контроллером кнопкой "Подключить". Для отключения связи нажать кнопку "Отключить". Если соединение не может быть установлено, ПО продолжает работать в режиме offline. Причиной отказа в установке соединения могут быть ошибки в задании параметров соединения. Необходимо устранить причину, по которой не может быть установлено online-соединение, а затем повторно нажать кнопку "Подключить".
После установления соединения из ПЛК читается информация о текущем проекте и отображается на экране ПДУ, как показано на рис. 3.2.2 Становятся доступными кнопки управления ПЛК.
Функции управления:
Местонахождение файла для режимов "запись" и "Чтение" задается в окне диалога.
Проект - это совокупность программ, данных и аппаратных конфигураций, необходимых для загрузки в ПЛК при решения поставленной задачи автоматизации. Создание проекта состоит в выполнении функций создания (или импорта), редактирования и сохранения его составных частей.
Основные этапы работы с проектом:
Функции кнопок управления:
Проект - это совокупность программ, данных и аппаратных конфигураций необходимых для загрузки в ПЛК при решения поставленной задачи автоматизации. Создание проекта состоит в выполнении функций создания (или импорта), редактирования и сохранения его составных частей.
В Фрегат2005 проект представлен как единый файл с набором программ и данных доступных в ходе работы с проектом. После создания проекта все задачи будут выполняться в рамках этого проекта. ПО допускает открытие только одного проекта для редактирования. Для совместимости с предыдущими версиями ПО предусмотрен режим импорта проекта.
Управление проектом выполняется с помощью: функций главного меню, кнопок главной панели инструментов и функций окна "Проекты". Кнопки панелей инструментов снабжены всплывающими окнами подсказок, содержащих функциональное назначение кнопок.
Создание нового проекта
Главное меню: "Файл"-"Новый"-"Проект".
Главная панель инструментов: кнопка 1.
Для создания нового проекта выберите в главном меню "Файл" - "Новый" - "Проект". На экране появится окно, соответствующее рис.3.6.1
Открыть проект
Главное меню: "Файл"-"Открыть"-"Проект.."
Главная панель инструментов: кнопка 2.
Панель инструментов окна "Проекты": кнопка "открыть".
Дополнительно: двойное нажатие указателем мыши на левый край строки списка сохраненных
проектов; Функциональная клавиша F3.
В появившемся диалоговом окне выбора проекта надо выбpать нужный файл c расширением "*.fgp".
Импорт проекта созданного в программах ФрегатПлюс или CPS
Главное меню: "Файл"-"Открыть"-"Импорт проекта Фрегат+,CPS.."
В появившемся диалоговом окне надо найти папку с проектами Фрегат2005, найти папку APL и выбpать нужный файл пpоекта с расширением "*.bin"
Сохранение проекта
Главное меню: "Файл"-"Сохранить"
Главная панель инструментов:кнопка 3.
Дополнительно: диалог сохранения проекта появится при попытке закрытия Фрегат2005 или
текущего проекта, если в него были внесены изменения с момента открытия.
В появившемся диалоговом окне задайте путь и наберите имя файла. Для сохранения нажмите клавишу [Enter], для отмены [Esc].
Сохранение и переименование проекта
Главное меню: "Файл"-"Сохранить как..."
В появившемся диалоговом окне задайте путь и наберите новое имя файла проекта.
Для сохранения нажмите клавишу [Enter], для отмены [Esc].
Закрыть текущий проект
Главное меню: "Файл"-"Закрыть".
Дополнительно: в главном меню "Файл"-"Выход" или нажатием кнопки закрытия главного окна.
Выбор в главном меню "Файл"-"Выход" или нажатие кнопки закрытия главного окна ПО
вызывает диалоговое окно в котором можно выбрать одно из действий: сохранять или не сохранять
текущий проект.
Управление программой выполняется с помощью кнопок панели инструментов и таблицы функциональных блоков окна "Программа", общий вид которого приведен на Рис. 3.3.3.1
Включает этапы:
Дополнительные возможности:
Поля таблицы "Включен", "Наименование", "Комментарий" переходят в режим редактирования щелчком мыши. Поля "Блок", "Вид" не редактируются пользователем.
Создание нового функционального блока
Панель инструментов: кнопка 1.
При нажатии на кнопку новый блок программы создается и открывается в редакторе языка
LAD (по умолчанию).
Данная кнопка содержит выпадающий список типов исходных текстов. Для выбора типа исходного текста открыть список и выбрать нужный тип нажатием указателя мыши.
При создании нового блока в таблице добавляется новая запись с номером блока, наименованием по умолчанию "Block"+ N, где N - очередной номер. Поле "Вид" содержит тип редактора, в котором данный блок был открыт последним.
Открытие функционального блока
Панель инструментов: кнопка 2.
Дополнительно: двойным щелчком мыши на левой части таблицы функциональных блоков.
Перед нажатием кнопок выбрать нужный функциональный блок в таблице
нажатием крайнего левого поля в нужной строке.
Для перевода созданного блока программы на другой язык программирования нажмите кнопку. На экране появится подменю, где надо выбрать язык, на который будет переводиться блок программы. Перед изменением языка программирования блока рекомендуется закрыть окно редактирования данного блока, если оно было открыто.
Изменение порядка сборки
Панель инструментов: кнопки 3,4.
Перед нажатием кнопок выбрать нужный функциональный блок в таблице
нажатием крайнего левого поля в нужной строке.
Порядок компиляции блоков (т. е. последовательность выполнения блоков программы) может быть важен в случае, когда состояние некоторого контакта меняется несколько раз в ходе выполнения скана программы.
Удаление функционального блока
Панель инструментов: кнопка 5.
Перед нажатием кнопок выбрать нужный функциональный блок в таблице
нажатием крайнего левого поля в нужной строке.
Перед выполнением удаления на экране появится окно-подтверждение "Удалить блок?", нажатие кнопки "Ок" вызывает удаление блока и стирание строки в таблице.
Дополнительные функции
Блоки программы можно временно исключать из списка компиляции. Для этого щелкните
правой кнопкой мыши на области поля "Включен" выбранного блока.
Импорт функционального блока
Панель инструментов: кнопка 8.
Добавить новый функциональный блок в программу можно, импортировав его из файла.
Экспорт функционального блока
Панель инструментов: кнопка 9.
перед нажатием кнопок выбрать нужный функциональный блок в таблице
нажатием крайнего левого поля в нужной строке.
Любой функциональный блок программы можно экспортировать (сохранить) в файл и потом использовать этот файл для импорта в другие проекты.
В исходных текстах программ Фрегат2005 используются символьные имена соответствующие контактам ввода-вывода и внутренним областям памяти контроллера. Распределение адресов символьных имен происходит при сборке проекта. Автоматическая система распределения адресов настраивается субмодулем "Таблица символов" на различные варианты аппаратной конфигурации. Сохранена возможность ручного назначения адресов.
Общий вид окна "ТаблицыСимволов" с элементами управления приведен на Рис. 2.5.2
Абсолютные адреса необходимы при формировании загружаемого в ПЛК файла программы. Использование абсолютных адресов в исходных текстах затрудняет написание программ и препятствует их повторному применению.
Фрегат2005 допускает применение абсолютных адресов в исходных текстах программ в целях совместимости со проектами ФрегатПлюс, предлагается альтернатива: символические имена и система автоматического распределения адресов.
Символическое имя
Символическое имя используется в исходных текстах программы для обозначения
одной или более ячеек некоторой области памяти ПЛК. Полный список символических имен хранится в
таблице символов, каждая строка которой соответствует одному символу. Поля внутри строки
содержат свойства символических имен, указанные в Таблице 3.3.4.
| Свойство | Наименование | Описание |
|---|---|---|
| Адрес | Адрес | Адрес в восьмеричной системе счисления |
| Тип распределения | ! | M:ручной,A:автоматический |
| Имя | Имя | Уникальное имя состоящее из допустимых символов |
| Тип памяти | Тип | I: внешний ввод-вывод; F: внутренний ввод-вывод;M: память данных. |
| Вход-выход | IO | 0: используется только для чтения; 1: используется для чтения и записи |
| Значение | = | Для типа М. Исходное значение |
| Размер | Размер | Длина имени: в битах для битовой области; в байтах для памяти данных. |
| Связь | Связь | Для типа I и автоматического распределения. Связь с контактом модуля ввода-вывода |
| Комментарий | Комментарий | Текстовое сообщение, выводимое для справки в редакторе и при печати проекта. |
Символическое имя является уникальным для проекта, то есть не должно повторяться в таблице имен. Созданное символическое имя может использоваться в любом функциональном блоке проекта.
Корректное символическое имя состоит из русских или латинских букв, цифр 0...9 и знаков подчеркивания "_". Пробелы и специальные символы в именах не допускаются.
Ввод нового символического имени
Панель инструментов: кнопка 1.
Дополнительно: в окнах редактирования при вводе исходных
текстов с использованием символов декорирования.
Ввод имен в режиме редактирования описан в разделе 3.3.5.
Открывается окно "Создать переменную", см. Рис. 3.3.4.2, содержащие кнопку "Создать" и поля: Имя, Адрес, Размер, Тип (памяти).
Необходимо задать уникальное имя и необходимые параметры, затем нажать кнопку "Создать". При создании выполняется проверка:
Остальные поля таблицы символов можно отредактировать позднее.
Символьным именам с автоматическим типом адреса присваиваются в начале сборки проекта. При наличии ошибок в таблице символов выводятся соответствующие текстовые сообщения в окно результатов сборки.
Алгоритм распределения адресов
Система распределения сортирует все символы по признаку "Тип памяти", образуя три группы
символических имен - по количеству областей памяти ПЛК. Внутри каждой группы символы
расположены в том же порядке, в котором они были введены в таблицу.
Для каждого символа выполняются действия:
Корректировка таблицы символов
Непосредственно в таблице символов можно изменить:
Поле "Связь"
Обеспечивает привязку символического имени к адресу выбранного контакта модуля ввода-
вывода. При сборке проекта с применением аппаратной конфигурации в окне "Аппаратура" напротив
прикрепленных к символьным переменным контактам будут стоять галочки.
Удалить неиспользуемые символические имена можно удалить с помощью кнопки 3 панели инструментов окна "Таблица символов".
Отменить сортировку имен можно с помощью кнопки панели инструментов окна "Таблица символов".
Сохранить в файл выделенные в таблице символов имена, нажав кнопку 6 набрав путь и имя файла. Имена сохраняются в специальном формате для последующего использования в других проектах Фрегат2005.
Ввести имена из файла в таблицу символов можно нажав кнопку 5 и набрав путь и имя файла.
Введенные в таблице символов имена можно использовать в любом из окон редактора сразу после их ввода. Таблица символьных имен сохраняется вместе с проектом.
Таблица перекрестных ссылок
Данная таблица для каждого из символических имен содержит перечень строк по количеству упоминаний символа в тексте программы с указанием места вызова (функциональный блок, цепь) и характера вызова (чтение или запись).
Таблица перекрестных ссылок выполняет задачи: определение количества и мест вызова символа, документирование проекта.
Таблица заполняется: 1) при импорте проекта 2) при сборке проекта. В ходе редактирования исходных текстов изменения перекрестных ссылок не фиксируются. Открыть(закрыть) таблицу перекрестных ссылок можно с помощью кнопки 2 панели инструментов окна "Таблица символов".
Функциональный блок на языке LAD состоит из цепей. Редактор отображает цепи в табличной форме с ячейками переменного размера. Цепь начинается строкой комментария (фон стального голубого цвета) и состоит из ряда строк схемы с элементами цепи (белый фон).
Строка цепи содержит пронумерованные позиции элементов и расположенные между ними позиции связей. Контакты могут располагаться только на пронумерованных позициях.
Основной набор команд редактирования выполняется кнопками панели инструментов.
Функции кнопок управления:
Действие команд редактирования выполняется для предварительно выбранного участка схемы.
Для выбора одиночного элемента или одной позиции связи необходимо щелкнуть указателем мыши над ним. Элемент будет отмечен синим цветом и тощиной линий.
При выборе области связи появляется квадратная метка наполовину заполненная черным цветом Рис.3.3.5.2. Заполнение метки задает направление действия, например, вставки элемента.
Для выбора всей цепи следует щелкнуть мышью над полем выбора строки 2 (поле серого цвета в левой части строки).
Для выбора группы элементов цепи нажать указателем мыши на краю участка и перемещать по диагонали до противоположного участка группы элементов Рис.3.3.5.3. После отпускания кнопки мыши все элементы в выбранном участке будут выделены в группу и очередная команда будет применена ко всем элементам данной группы (вставка, удаление или замена).
Кнопка 1 Рис. 3.3.5.1 "Добавить цепь" .
Новая цепь вставится:
Кнопки 2 и 3 Рис. 3.3.5.1 "Добавить контакт", "Добавить контакт НЕ"
Нажатие кнопок вставляет новый элемент в предварительно выбранном месте. Необходимо учитывать направление действия, указанное меткой.
Кнопка 4 Рис. 3.3.5.1 "Катушка, счетчик, таймер, функция"
Добавляет завершающую часть выделенной цепи. Нажатие данной кнопки вызывает вставку катушки. Для ввода таймера, счетчика или функции выбрать нужный элемент из выпадающего списка. Особенность ввода функции заключается в необходимости выбора строки нужной команды из таблицы окна диалога "Функциональные команды", которое открывается при вводе функции.
Кнопка 5 Рис. 3.3.5.1 "Вырезать". Копирует в буфер и удаляет элементы выбранного участка.
Кнопка 6 Рис. 3.3.5.1 "Копировать". Копирует в буфер выделенный участок (контакт или группа контактов).
Кнопка 7 Рис. 3.3.5.1 "Вставить". Предварительно скопированные элементы вставляются в выбранное место. В зависимости от типа выбора участка выполняется вставка или замена элементов. При замене сложных участков цепей вначале выбранные элементы удаляются, в место нахождение последнего удаляемого элемента вставляется фрагмент из буфера.
Ввод параллельных элементов Рис.3.3.5.3.
Элемент может быть вставлен параллельно одному или нескольки элементам, а также сложной группе элементов включающей параллельные и последовательные соединения.
Щелчок указателем мыши точно на метке в области связи обозначает начальную точку вставки элемента. Левая кнопка мыши означает вставку нормально разомкнутого, а правая - нормально замкнутого контакта. Перемещение указателя в конечную точку сопровождается изображением вставляемого элемента.
Разрешенные позиции вставки отображаются в областях связи при нахождением указателя над ними. Второй щелчок точно над меткой соединения указывает место вставки элемента.
Для отмены всех изменений с момента открытия окна редактора выполните пункт главного меню "Правка" - "Отменить".
Катушки и контакты определяются единственным параметром - адресом контакта. Таймер и счетчик дополнительно определяются числом тактов. Число и тип параметров функции определяется ее номером.
Ввод символических имен.
При выборе одиночного элемента цепи области ввода параметров изображены прямоугольниками с серым фоном. Щелчок мыши по области ввода открывает текстовое окно редактирования параметра, снабженное всплывающей подсказкой Рис.3.3.5.4. Если параметр является символическим именем, повторный щелчок на текстовом окне редактирования открывает полный список имен для возможного выбора.
Ввод новых символических имен
При вводе нового символического имени в поле параметра редактируемого элемента можно одновременно добавить его в таблицу символов. Для этого следует указать перед именем символ декорирования в соответствии с нужной областью памяти.
Символ декорирования вводится без пробелов перед символическим именем.
| Символ | Область распределения | Тип распределения |
|---|---|---|
| ! | Ввод-вывод | Авто |
| ? | Фиктивный ввод-вывод | Авто |
| @ | Память данных | Авто |
| $ | Адрес указан в команде | Ручной |
В конце имени можно в квадратных скобках указывать размерность создаваемой области. Для доступа к адресам области символы указываются также с индексом, начиная с нуля.
Примеры декорированных имен:
| Декорированное имя | Результат |
|---|---|
| !START | Имя в области ввода-вывода авто-распределение |
| ?FUN56[3] | Имя в области фиктивного ввода-вывода авто-распределение, длина - 3 бита |
| @MEM[8] | Имя в области памяти, длина 8 байт |
| $400 | Имя в области ввода-вывода, адрес 04008, длина - 1 бит |
Особенность ввода имен для функций
Для функций размерность области указывать не нужно, так как создается набор переменных в соответствии с количеством используемых вводов-выводов.
Для создания блока в редакторе STL необходимо воспользоваться кнопками панели инструментов "Программа" "Новый блок". В выпадающем меню выберите язык STL (щелкните левой кнопкой мыши). Новый блок программы откроется в редакторе мнемокода .
Для открытия блока в редакторе STL необходимо воспользоваться кнопками панели инструментов "Открыть как..". В выпадающем меню выберите язык STL (щелкните левой кнопкой мыши). Выбранный блок программы откроется в редакторе мнемокода Рис.3.3.6.3.
Каждая цепь в редакторе STL Рис.3.3.6.3 состоит из:
В редакторе STL доступно только редактирование символических имен и параметров таймеров, счетчиков и функций
Для редактирования параметров щелкнуть мышью на выбранном элементе. Редактируемые поля будут отмечены серым фоном. Повторный щелчок на поле параметра открывает его текст для редактирования. Для символических имен можно воспользоваться выбором имени из выпадающего списка.
Цель конфигурирования - это автоматизированная настройка проекта на используемый набор модулей ввода-вывода.
Конфигурирование является необязательной процедурой, так как для правильной работы программы достаточно присвоить символическим именам области ввода-вывода адресов соответствующих модулям ввода-вывода, что может быть выполнено в режиме ручного распределения.
Конфигурирование позволяет получить более качественный проект, который можно целиком или по частям использовать повторно с минимальными корректировками при возможном изменении ассортимента модулей ввода-вывода и (или) адресации модулей.
Для конфигурирования аппаратного обеспечения необходимо выполнить следующее Рис.3.4.1.1 :
Функции кнопок управления:
Кроме создания конфигурации доступны действия:
Для начала работы с заданной конфигурацией следует нажать кнопку "Применить конфигурацию" кнопка 4 Рис. 3.4.1.2.
При работе с заданной конфигурацией система автоматического распределения адресов для ввода-вывода использует только адреса установленных модулей.
Если для символического имени задано поле связи и автоматическое распределение, адрес имени присваивается с учетом базового адреса модуля плюс смещения контакта от начала модуля.
Перемещение модулей
Вы можете перемещать модули или другие компоненты из одного слота в другой с помощью мышки.
Замена базовых адресов модулей
Можно изменять начальный адрес модуля. При этом для дальнейшей работы достаточно сгенерировать программу с привязкой конфигурации, и символьным переменным присвоятся новые адреса.
Замена модулей
Если конфигурация уже создана и необходимо заменить модуль другим модулем из каталога аппаратных средств, то выполните следующее:
Применение конфигурации для импортированных проектов
Импорт проектов "ФрегатПлюс", "CPS" выполняется с установкой ручного распределения для всех символических имен. Для перевода в режим автоматического распределения:
Сборка программы - это преобразования проекта в файл с расширением "*.bin", готовый для записи в контроллер.
Запуск сборки возможен из панели "Программа" - кнопки 6 и 7 или "Редактор Lad" - кнопки 9 и 10 .
Процесс сборки и возможные ошибки отображаются на панели "Сообщения" - "Результаты сборки". При наличии ошибок появляется диалоговое окно с сообщением об ошибке.
В результате сборки, при отсутствии ошибок, создается файл program.bin, который может быть записан в контроллер.
После того, как разработан проект и написана программа, начинается этап отладки.
Для проведения отладки удаленного контроллера необходимо открыть модуль связи, и устанавить связь между Фрегат2005 и ФрегатСервер на удаленном компьютере.
Отладка может проводиться:
Для проведения отладки программы в режиме симуляции необходимо выполнить следующие действия:
Для отображения конкретного участка данных на экране компьютера необходимо в окне модуля связи в левом крайнем поле набрать адрес, содержимое которого Вы хотите посмотреть и перевести курсор в другое нижнее поле. Только после этого на одной линии с введенным адресом начнет отображаться содержимое памяти в числовом виде и в виде загорающихся индикаторов Рис.3.6.2.1.
Процесс отладки можно наблюдать и в режиме подсветки проводимости контактов в редакторе Lad. Для этого перейдите в редактор и нажмите на кнопку 1 Рис.3.6.1.3. Активные контакты будут выделяться ярко-синим цветом.
Функции отладки обеспечивают контроль состояния областей ввода-вывода и памяти ПЛК в ходе
выполнения программы в непрерывном или пошаговом режиме. Состояние областей ввода вывода может
быть отражено на схеме цепи в редакторе LAD.
Основной набор задач отладки доступен из окна модуля "ПДУ", Рис.3.2.1.
Состояния областей ввода-вывода отображаются на индикаторах в нижней части окна модуля "ПДУ". Состояния обновляются циклически. Общая длительность цикла отображается на панели модуля связи и определяется суммой времен: опроса ПЛК, отображения информации и паузы управляемой длительности. Выпадающий список в правой части панели управления (см. Рис.3.6.2.1) задает длительность паузы.
Каждый индикатор выполнен в виде блока с полями (см. Рис.3.6.2.3, 3.6.2.4):
При вводе корректного адреса в соответствующее поле индикатор включается в цикл опроса контроллера и отображает полученные данные в поле данных. Ввод базового адреса начинается при двойном нажатии клавиши мыши над полем адреса и завершается после нажатия клавиши "Enter" , либо после нажатия указателем мыши на другом индикаторе.
Недопустимый адрес отображается красным цветом, при этом область данных не обновляется. Для отключения индикатора можно ввести в поле адреса знак "-". Состояние битовой области кроме поля данных отображается также с помощью световой индикации. Темный цвет индикатора соответствует 0, яркий -1.
Функции отладки доступны из редактора Lad путем включения в режим слежения, как показано на Рис. 2.6.2 кнопка 11.
| Тип индикатора | Тип области | Допустимые адреса |
|---|---|---|
| Битовая область | Ввод-вывод, фиктивный ввод-вывод | 0...037778 |
| Байтовая область | Банки памяти | X40008...X77778, где X - номер банка памяти 0...7 |
В данном режиме состояние контактов в выбранной цепи отображается на схеме Lad. Контакты в состоянии
"1" выделяются синим цветом и толщиной линий.
При выборе цепи для слежения редактор Lad взаимодействует с модулем "ПДУ": составляется список
контактов и в окне модуля "ПДУ" добавляется один или несколько индикаторов с нужным базовым
адресом.
Режим слежения выключается при закрытии окна редактора Lad.
Пошаговая отладка возможна только в симуляторе. Нажимая кнопку "Шаг" осуществляйте шаги по программе.
Фрегат2005 позволяет управлять ПЛК дистанционно, как через локальную сеть, так и через глобальную.
Можно на pасстоянии включить и выключить УПУ-ТП, запpетить/pазpешить обмен с модулями ввода/вывода, перезаписать программу, выполнять пpогpамму по сканам/циклически.
Для удаленного управления на компьютере, к которому подключен ПЛК должна быть установлена и запущена программа FServer.exe. На другом компьютере должна быть установлен и запущен базовый модуль fgat2005.exe.
После установления связи с удаленным компьютером последовательность действий при отладке аналогична п.3.6.2.